MP-BGP peering Sample network topology and configurations
Let's consider a simple Toplogy diagram as shown below:
Configuration of R1:
===============
hostname R1
!
ip cef
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.0
!
interface Serial1/0
ip address 20.16.10.1 255.255.255.0
mpls ip
clock rate 2000000
!
router bgp 5500
no synchronization
bgp router-id 10.10.10.10
bgp log-neighbor-changes
redistribute connected
neighbor 20.16.10.2 remote-as 6500
neighbor 20.16.10.2 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 20.16.10.2 activate
neighbor 20.16.10.2 send-community both
!--- Sends the community attribute to a BGP neighbor.
exit-address-family
!
!
end
Configuration of R2:
===============
!
hostname R2
!
ip cef
!
ip vrf WAN
rd 2020:1
route-target export 2020:1
route-target import 2020:1
!
interface Loopback0
ip vrf forwarding WAN
ip address 20.20.20.20 255.255.255.255
!
interface Serial1/0
ip vrf forwarding WAN
ip address 20.16.10.2 255.255.255.0
mpls ip
serial restart-delay 0
clock rate 2016000
!
!
interface Ethernet2/0
ip address 192.168.112.180 255.255.255.0
duplex half
!
!
router bgp 6500
no synchronization
bgp router-id 20.20.20.20
bgp log-neighbor-changes
neighbor 20.16.10.1 remote-as 5500
neighbor 192.168.114.36 remote-as 6500
no auto-summary
!
address-family vpnv4
neighbor 20.16.10.1 activate
neighbor 20.16.10.1 send-community both
neighbor 192.168.114.36 activate
neighbor 192.168.114.36 send-community extended
exit-address-family
!
address-family ipv4 vrf WAN
redistribute connected
redistribute static
neighbor 20.16.10.1 remote-as 5500
neighbor 20.16.10.1 activate
no synchronization
exit-address-family
!
ip forward-protocol nd
ip route 192.168.0.0 255.255.0.0 192.168.112.1
!
end
Verify MP BGP configurations:
Configuration of R1:
===============
hostname R1
!
ip cef
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.0
!
interface Serial1/0
ip address 20.16.10.1 255.255.255.0
mpls ip
clock rate 2000000
!
router bgp 5500
no synchronization
bgp router-id 10.10.10.10
bgp log-neighbor-changes
redistribute connected
neighbor 20.16.10.2 remote-as 6500
neighbor 20.16.10.2 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 20.16.10.2 activate
neighbor 20.16.10.2 send-community both
!--- Sends the community attribute to a BGP neighbor.
exit-address-family
!
!
end
Configuration of R2:
===============
!
hostname R2
!
ip cef
!
ip vrf WAN
rd 2020:1
route-target export 2020:1
route-target import 2020:1
!
interface Loopback0
ip vrf forwarding WAN
ip address 20.20.20.20 255.255.255.255
!
interface Serial1/0
ip vrf forwarding WAN
ip address 20.16.10.2 255.255.255.0
mpls ip
serial restart-delay 0
clock rate 2016000
!
!
interface Ethernet2/0
ip address 192.168.112.180 255.255.255.0
duplex half
!
!
router bgp 6500
no synchronization
bgp router-id 20.20.20.20
bgp log-neighbor-changes
neighbor 20.16.10.1 remote-as 5500
neighbor 192.168.114.36 remote-as 6500
no auto-summary
!
address-family vpnv4
neighbor 20.16.10.1 activate
neighbor 20.16.10.1 send-community both
neighbor 192.168.114.36 activate
neighbor 192.168.114.36 send-community extended
exit-address-family
!
address-family ipv4 vrf WAN
redistribute connected
redistribute static
neighbor 20.16.10.1 remote-as 5500
neighbor 20.16.10.1 activate
no synchronization
exit-address-family
!
ip forward-protocol nd
ip route 192.168.0.0 255.255.0.0 192.168.112.1
!
end
Verify MP BGP configurations:
MP-BGP --> By Indu |
Comments