Advance BGP Configuration

In this blog, i provide the detailed steps for configuring the bgp. I use the above topology to configure the bgp. In the above topology, i'm going to configure ebgp between R5 & R1 and between R4 & R3.
In the core Autonomous system AS100, i'm going to configure the eigrp protocol. The most important thing you should keep in mind is, the neighbour id is the loopback ip address for all the bgp nodes. However, in the case of e-bgp the TTL is always set to 1, which causes the packets to get dropped while setting up the TCP connection. & hence i'll enforce the TTL value to 2 using ebgp-multihop 2 command. Rest of the things are pretty much straight forward, just try out the configurations in your setup, you will learn easily. Following are the steps you need to follow to configure the bgp on the above topology.

Step1:  Lets configure the router R5:

interface Loopback0
ip address 5.5.5.5 255.255.255.255
interface Loopback1
ip address 55.55.55.55 255.255.255.0
interface Loopback2
ip address 56.56.56.56 255.255.255.0
interface FastEthernet0/0



 ip address 50.50.50.5 255.255.255.0
ip route 1.1.1.1 255.255.255.255 50.50.50.1
router bgp 500
network 55.55.55.0 mask 255.255.255.0
network 56.56.56.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
no auto-summary

Step2: Lets Configure the Router R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.255
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
interface FastEthernet1/0
ip address 50.50.50.1 255.255.255.0
router eigrp 100
redistribute connected
redistribute static
redistribute bgp 100
network 1.1.1.1 0.0.0.0
network 10.10.10.0 0.0.0.255
no auto-summary
router bgp 100
no synchronization
redistribute eigrp 100
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 5.5.5.5 remote-as 500
neighbor 5.5.5.5 ebgp-multihop 2
neighbor 5.5.5.5 update-source Loopback0
no auto-summary
ip route 5.5.5.5 255.255.255.255 50.50.50.5

Step3: Lets Configure Router R2:

interface Loopback0
ip address 2.2.2.2 255.255.255.255
interface FastEthernet0/0
ip address 10.10.10.2 255.255.255.0
interface FastEthernet1/0
ip address 20.20.20.2 255.255.255.0
router eigrp 100
network 2.2.2.2 0.0.0.0
network 10.10.10.0 0.0.0.255
network 20.20.20.0 0.0.0.255
no auto-summary
router bgp 100
no synchronization
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 route-reflector-client
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 route-reflector-client


 no auto-summary

Step4: Lets Configure Router R3:

interface Loopback0
ip address 3.3.3.3 255.255.255.255
interface FastEthernet0/0
ip address 20.20.20.3 255.255.255.0
interface FastEthernet1/0
ip address 30.30.30.3 255.255.255.0
router eigrp 100
redistribute connected
redistribute static
redistribute bgp 100
network 3.3.3.3 0.0.0.0
network 20.20.20.0 0.0.0.255
no auto-summary
router bgp 100
no synchronization
redistribute eigrp 100
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 4.4.4.4 remote-as 400
neighbor 4.4.4.4 ebgp-multihop 2
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
ip route 4.4.4.4 255.255.255.255 30.30.30.4

Step5: Lets Configure Router R4:

interface Loopback0
ip address 4.4.4.4 255.255.255.255
interface Loopback1
ip address 44.44.44.1 255.255.255.0
interface Loopback2
ip address 45.45.45.1 255.255.255.0
interface FastEthernet0/0
ip address 30.30.30.4 255.255.255.0
router bgp 400
no synchronization
network 44.44.44.0 mask 255.255.255.0
network 45.45.45.0 mask 255.255.255.0
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
ip route 3.3.3.3 255.255.255.255 30.30.30.3

Now verify the configurations using these commands:
1> show ip bgp 
2> show ip bgp sum
3> show ip route

Now, try to ping from R5 to R4; it should be successful. 

Comments